Welcome to the Gamebase 64 forums.                 An attempt to document ALL Commodore 64 gameware before it's too late!

Strange message on GBC_v09

Are you having problems setting up GB64 on your machine? Ask your questions in here!

Moderator: Jimbo

dax
Ice Cool Member
Ice Cool Member
Location: Poland
Posts: 687
Joined: Tue Sep 04, 2007 1:45 pm

Strange message on GBC_v09

Sun Aug 05, 2012 9:51 pm

Hi, there :)

message I see in frontend, after 2xclicking a game is :

GEMUS ERROR window.
Invalid file referenced in script function.
Do You want to continue running the game anyway ?


And when I click YES, it runs game in emulator.
But I don't know why this error message appears and what to do to remove it :). I did not messed up with database (untouched). Only paths changed from "e:\gamebase\......" to ".\...."
I love Gamebase's creators and compilations
Hidron
Cool Member
Cool Member
Location: USA
Posts: 393
Joined: Sun Feb 13, 2011 5:05 pm

Sun Aug 05, 2012 10:41 pm

Hmm. I haven't had any trouble yet. Working on a fresh install of Gamebase myself. I had just formatted my machine last weekend. I did copy over my Emulators folder & paths.ini, emulators.ini & musicplayers.ini from my v08 folder.

Are you using the new gemus & script files? Except for the Hoxs script they were all updated for v09.

Edit: btw, I edit my files to the .\ pathing too.

Edit#2: In some further checking, I found 2 other threads here that both point toward a problem with the frontend failing to find the emulator config files (vice.ini or c64.cfg), so you may check the pathing listed for them in your emulators.ini file.
I have a lot of respect for Gamebase creators, maintainers & supporters.
dax
Ice Cool Member
Ice Cool Member
Location: Poland
Posts: 687
Joined: Tue Sep 04, 2007 1:45 pm

Mon Aug 06, 2012 5:03 pm

I've used scripts from v8 and v9. Used almost properly configured INI's from v8. Problem was probably with entry "1=.\commodore 64\Emulators\WinVICE-2.2\vice.ini", which not pointed to directory\vice.ini (like now), but only to file.

So, solved. Tnx for reply ;)
I love Gamebase's creators and compilations
User avatar
Retroplay
Cool Member
Cool Member
Location: Denmark
Posts: 282
Joined: Sun Apr 18, 2004 10:18 pm

Thu Aug 09, 2012 1:01 pm

Hidron wrote:Are you using the new gemus & script files? Except for the Hoxs script they were all updated for v09.
T64 works with Hoxs, maybe not with older versions, 1.0.7.4 is fine.
Just add T64 to SupportedTypes in emulators.ini and you're good to go.

Return to “GB64 Help!”

Who is online

Users browsing this forum: No registered users and 2 guests